On 12/31/20 9:55 AM, Tony Langdon via 44Net wrote:
And then there's people like me. I'm more
than the typical user - I run
a rather complex network here, with multiple subnets on the one wire,
and even have to policy route at a few points to keep it all going. But
I don't (currently) have the WAN knowledge and experience to run a POP
that might have to participate using BGP, etc (I've never been hands on
with BGP, for example - I just know it exists and have an idea what it
does).
I am also likely to need a bunch of addresses, so where do I fit in the
grand scheme of things?
Running BGP on an endpoint just to tell the POP what networks you want
to receive is very easy. It is easiest when you have a router that has
streamlined the configuration of BGP a little. E.g. on a MikroTik you
would just need this (it can be entered via commandline or via GUI clicks):
/routing bgp instance
set default as=42xxxyyyzz
/routing bgp network
add network=44.xx.yy.zz/nn
add network=44.xx.yy.zz/nn
/routing bgp peer
add default-originate=if-installed name=somename nexthop-choice=force-self \
remote-address=44.aaa.bb.cc remote-as=42pppqqrr ttl=1
That will tell the router to connect to the peer (the POP) and advertise a
few networks. The peer will route those networks to you, and you receive the
routes to other networks via the peer.
The AS numbers are from the private AS range and have a structure that
allows local assignment of numbers (just like IP subnets). It is already in
use in several places.
This can be further tweaked e.g. when you have only a single peer you can
just receive a large route from them instead of all the detail routes that all
point the same direction.
But it is not rocket science. And when using software on a Linux box that
you have to configure yourself (quagga, bird) the principle is the same, you
just may need a somewhat larger configuration file but that would mostly
be the same for everyone so examples can be published.
Rob