RouterOS cannot handle this, but Linux can. E.g.:
node has subnet 44.137.40.0/23 and has address 44.137.41.254
user has subnet 44.137.41.96/28 and has address 44.137.41.110 on eth0
then:
ip route add 44.0.0.0/8 dev eth0 gw 44.137.41.254 onlink
To do this in RouterOS (and in many other routers) you need to set the
subnet mask
to /23 on the eth0, but that means it will try to contact the others
directly, not routing via the node.
This will work when the local area is switching/bridging.
Otherwise you will need to have a node address in everyone's subnet.
The same situation occurs when setting up the P2MP IPIP tunnel
interface: you assign it the
subnet of your local system, so all the routes are outside the
interface's subnet and need
the "dev" and "onlink" parameters. RouterOS does not support them.
But Linux does.
You might not have found the solution yet. But RouterOS DOES support PtP
addressing on PtMP interfaces.
/ip address add 44.137.41.110/32 network=44.137.41.254 interface=ether1
/ip route add dst-address=44.0.0.0/8 gateway=44.137.41.254
73 de Marc, LX1DUC