The /8 is needed to get the RIP announcements which need to have both
endpoints in the same network to receive multicast RIP.
You just need to have some unused 44.56.53.x/8 on the ucsd-gw. It does not
matter what it is.
Since that one will land on the vrf, it will not bother you and will not
interfere with your regular routes..
My setup:
Router public IP: 89.122.215.236 via PPPoE
Router ampr IP: 44.182.21.254
/ip route vrf add interfaces=ucsd-gw routing-mark=44net
/ip address add address=44.182.21.254/8 interface=ucsd-gw network=44.0.0.0
/ip address add address=44.182.21.254/24 interface=bridge-ampr
network=44.182.21.0 <-- this is my local LAN
/routing prefix-lists
add action=discard chain=ampr prefix=44.0.0.1/32
add chain=ampr prefix=44.0.0.0/8
add action=discard chain=ampr
add action=discard chain=none
add chain=all
/routing rip
set garbage-timer=20m routing-table=44net timeout-timer=10m update-timer=5m
/routing rip interface
add authentication=simple authentication-key=<rip_password>
in-prefix-list=ampr interface=ucsd-gw out-prefix-list=none passive=yes
receive=v2
/routing rip network
add network=44.0.0.0/8
This gives me RIP routes in passive mode, as needed by the script.
Marius, YO2LOJ
-----Original Message-----
From: Leon Zetekoff
Sent: Wednesday, February 24, 2016 15:31
To: 44net(a)hamradio.ucsd.edu
Subject: Re: [44net] RIP broadcast based AMPR gateway script for Mikrotik
routers
(Please trim inclusions from previous messages)
_______________________________________________
Hi Marius...
does this look right?
My local Public is 24.115.112.147
My AMPRnet allocation is 44.56.53.1/28
I've defined 44.56.53.1/28 on physical ether 3
I was a little confused about the /8 on the ip address below seeing your
defining the full /8 for AMPR net?
Having a real world commented example in the script would help.
many thanks 73 leon
====================
/interface ipip add !keepalive clamp-tcp-mss=yes
local-address=24.115.112.147 \
remote-address=169.228.66.251 name=ucsd-gw
/ip address add address=44.56.53.1/8 interface=ucsd-gw network=44.0.0.0
# To be able to receive RIPv2 broadcasts into a specific table, first
create a VRF:
/ip route vrf add interfaces=ucsd-gw routing-mark=44rip
# and activate passive RIP for that routing table:
/routing rip set garbage-timer=20m routing-table=44rip timeout-timer=10m
update-timer=5m
/routing rip interface add authentication=simple
authentication-key=ThePAssword \
in-prefix-list=all interface=ucsd-gw out-prefix-list= none
passive=yes receive=v2
/routing rip network add network=44.0.0.0/8
_________________________________________
44Net mailing list
44Net(a)hamradio.ucsd.edu
http://hamradio.ucsd.edu/mailman/listinfo/44net